Maintenance
Incident Report for NFL All Day
Resolved
This incident has been resolved.
Posted Jan 18, 2023 - 19:13 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 18, 2023 - 19:03 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 18, 2023 - 19:01 UTC
This incident affected: Overall Website, Signup and Login, Pack Purchasing, Queue, Pack Opening, and User Profile.