Scheduled maintenance
Incident Report for NFL All Day
Resolved
Scheduled maintenance has completed.
Posted Nov 02, 2022 - 16:53 UTC
Investigating
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 02, 2022 - 14:39 UTC
This incident affected: Pack Purchasing, Queue, and Pack Opening.